[PATCH v2 0/1] Fix perl error "unescaped left brace in regex" for paranoid update hook
To
git@vger.kernel.org
Cc
Junio C Hamano
From
Dominic Winkler via GitGitGadget
See Also
Prev
Date
2019-09-11 21:47:21 UTC
A literal "{" should now be escaped in a pattern starting from perl versions
>= v5.26. In perl v5.22, using a literal { in a regular expression was
deprecated, and will emit a warning if it isn't escaped: {. In v5.26, this
won't just warn, it'll cause a syntax error.

(see https://metacpan.org/pod/release/RJBS/perl-5.22.0/pod/perldelta.pod)

Signed-off-by: Dominic Winkler d.winkler@flexarts.at [d.winkler@flexarts.at]

Dominic Winkler (1):
  contrib/hooks: escape left brace in regex in the paranoid update hook

 contrib/hooks/update-paranoid | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 5fa0f5238b0cd46cfe7f6fa76c3f526ea98148d9
Published-As: https://github.com/gitgitgadget/git/releases/tag/pr-335%2Fflexarts%2Fmaint-update-paranoid-perlv5.26-v2
Fetch-It-Via: git fetch https://github.com/gitgitgadget/git pr-335/flexarts/maint-update-paranoid-perlv5.26-v2
Pull-Request: https://github.com/gitgitgadget/git/pull/335

Range-diff vs v1:

 1:  2743caa22e ! 1:  0d762cfb50 Fix perl error "unescaped left brace in regex" for paranoid update hook
     @@ -1,6 +1,6 @@
      Author: Dominic Winkler <d.winkler@flexarts.at>
      
     -    Fix perl error "unescaped left brace in regex" for paranoid update hook
     +    contrib/hooks: escape left brace in regex in the paranoid update hook
      
          A literal "{" should now be escaped in a pattern starting from perl
          versions >= v5.26. In perl v5.22, using a literal { in a regular

-- 
gitgitgadget