Re: [PATCH] gitweb: fix UTF-8 encoding when using CGI::Fast
To
Julien Moutinho
Cc
git@vger.kernel.org
From
Junio C Hamano
See Also
Prev
Date
2020-03-29 16:06:24 UTC
Julien Moutinho <julm+git@sourcephile.fr> writes:

>  	require CGI::Fast;
>  	our $CGI = 'CGI::Fast';
> +	# FCGI is not Unicode aware hence the UTF-8 encoding must be done manually.
> +	# However no encoding must be done within git_blob_plain() and git_snapshot()
> +	# which must still output in raw binary mode.

I guess this comment would be sufficient to help future developers
when they find that newer version of CGI::Fast has become Unicode
aware later can make this part conditional to the version of the
module, perhaps?

Would "use CGI::Fast (-utf8)" instead of the whole thing help, by
the way?

> +	no warnings 'redefine';
> +	my $enc = Encode::find_encoding('UTF-8');
> +	*FCGI::Stream::PRINT = sub {
> +		my @OUTPUT = @_;
> +		for (my $i = 1; $i < @_; $i++) {
> +			$OUTPUT[$i] = $enc->encode($_[$i], Encode::FB_CROAK|Encode::LEAVE_SRC);
> +		}
> +		@_ = @OUTPUT;
> +		goto $FCGI_Stream_PRINT_raw;
> +	};



>  	my $request_number = 0;
>  	# let each child service 100 requests
> @@ -7079,6 +7093,7 @@ sub git_blob_plain {
>  			($sandbox ? 'attachment' : 'inline')
>  			. '; filename="' . $save_as . '"');
>  	local $/ = undef;
> +	local *FCGI::Stream::PRINT = $FCGI_Stream_PRINT_raw;
>  	binmode STDOUT, ':raw';
>  	print <$fd>;
>  	binmode STDOUT, ':utf8'; # as set at the beginning of gitweb.cgi
> @@ -7417,6 +7432,7 @@ sub git_snapshot {
>  
>  	open my $fd, "-|", $cmd
>  		or die_error(500, "Execute git-archive failed");
> +	local *FCGI::Stream::PRINT = $FCGI_Stream_PRINT_raw;
>  	binmode STDOUT, ':raw';
>  	print <$fd>;
>  	binmode STDOUT, ':utf8'; # as set at the beginning of gitweb.cgi